Run As Administrator - Video/sound settings difference

Report all the issues and bugs you can find for VF_WoWLauncher here.

Run As Administrator - Video/sound settings difference

Postby Nebelung » 22 Jul 2017, 00:39

Hi there,

I got an issue with the launcher or Run As Administrator.

My sound and video settings are configurated ingame.
But when I start WoW as Administrator he takes different sound and video settings.

This also happens when I start Wow from the launcher, it's the same effect.
Isn't there a way to configurate Wow how I want to and when I "Run As Administrator" he takes those settings as well?
You can't tell me I have to play in two versions? This is so weird, am I alone in this?

I know the simple solution will be, don't run in administrator, but I just want to know why this is happening, because I rather run it as recommended.

Thanks a lot!
Nebelung
 
Posts: 1
Joined: 16 Jul 2017, 12:26

Re: Run As Administrator - Video/sound settings difference

Postby Dilatazu » 29 Aug 2017, 21:34

Hi,

The reason why running as Administrator is works different is most likely because you have Wow installed on C:/ drive. If you have it on C:/ drive, because the way Windows operating system works nowadays is that it does not give Wow permission to write files there. So it puts them all in a folder inside your "user" folder and then virtually tells wow that the files is actually inside its folder when it is not. When you then run as administrator it has the permissions to write on C:/ and so writes inside the folder. Writing inside the folder is needed for Launcher to work correctly.

Install wow on D:/ drive and you will probably not have these kind of issues, because there wow can write files no matter what.

I could be wrong with all these assumptions and some info here. I forgot myself how it all works.

But hopefully this is helpful explanation/information.

Thanks for the feedback.
Dilatazu
Site Admin
 
Posts: 759
Joined: 24 Feb 2014, 17:19
Location: Sweden


Return to Issues and bug reports

Who is online

Users browsing this forum: No registered users and 2 guests

cron