For Linux

Default section for everything that is not a suggestion or bug report for VF_WoWLauncher.

Re: For Linux

Postby Dilatazu » 16 Feb 2016, 23:12


As far as i know only .NET 4.0 should be used. But maybe the installer is using another older version(i have not recompiled it since the start of the project pretty much, there is an small issue that keeps me from doing it).

Although i guess wyUpdate and some other 3rd party dependencies might use something else.

On windows environment most of the .NET versions are already installed, either by other apps or as windows update.
I do agree that making sure it is only using one .NET version would be the best, but i have so far prioriticed features and stability over such details. The project is huge with many parts and unfortunately i am the only developer.

If i find the motivation and time to do some more work on the wowlauncher i will be sure to keep this in mind.
Site Admin
Posts: 759
Joined: 24 Feb 2014, 17:19
Location: Sweden

Re: For Linux

Postby theoden » 17 Feb 2016, 22:39

It seems wyUpdate requires .NET 2.0, see section "wyUpdate Requirements" of its docs.

I'll give it a try by installing dotnet20 at my wine environment. Stay tuned.
Posts: 5
Joined: 10 Feb 2016, 21:12

Full guide for the launcher installation in linux

Postby theoden » 20 Feb 2016, 09:14

Hello everyone, we've got a semi-win.

Here's the full guide how to install VF_WoWLauncher under the amd64 (64-bit) linux. Tested on ubuntu 14.04.

  1. Install wine and its cute manager winetricks if you haven't:
    Code: Select all
    sudo apt install wine winetricks
  2. .NET 4.0 doesn't work with 64-bit wine, so we have to create a separate 32-bit wineprefix (see the guide mentioned upper for the details):
    Code: Select all
    export WINEARCH='win32'
    export WINEPREFIX=~/.wine-dotnet/
    wineboot -u
  3. Now we need to install all the dependencies in this wineprefix. Continue in the same terminal where you've input previous commands.
    Code: Select all
    winetricks dotnet40
    winetricks dotnet20
    winetricks wsh57
  4. After that you'll be able to just run
    Code: Select all
    wine VF_WoWLauncherInstaller.exe
    (using the created 32-bit wine prefix!) and have your launcher installed and running.

I can't find a spoiler tag, so I put the dependencies details in a quotation.


Actually, the next problem I've met is that, er, wow cannot be launched by the launcher. :-) @Dilatazu, I need your help very much, since the error is very vague.

Why might it happen, how do you think?

I thought about "WoW" case which does matter on *NIX OSes, so I renamed my "WoW.exe" into "wow.exe" but that didn't help.

Again, Dilatazu, personally I and all the linux part of the community, I think, will appreciate your help very much.
Thanks in advance!
Posts: 5
Joined: 10 Feb 2016, 21:12

Re: For Linux

Postby Dilatazu » 22 Feb 2016, 23:05

Hey theoden,

Thanks for taking the time investigating and coming up with solutions to some of the problems!

Looks like you have made some progress :)

The error you received is related to the application not being able to find the wow process. The wow process is used to be able to know if the wow has loaded or not. What is happening is the application is simply looking at the process list until it finds a new wow process pop up.

I think maybe it is possible to solve this issue by ensuring you have administrator rights whatever that means in linux/wine. Make sure the installer and launcher managed to install all its files in the directory. there should be some .bat files that are generated, if they are missing it can create issues.

Did this error happen before you configured a UserID or after? Is it the only error you noticed so far?

I do not think it has anything to do with the wow.exe filename.

Thanks for the feedback!
Site Admin
Posts: 759
Joined: 24 Feb 2014, 17:19
Location: Sweden

Re: For Linux

Postby Strudel » 23 Feb 2016, 16:53

AFAIK: Wine applications are always running with Administrator privileges. The Windows user should be "Administrator".

edit source:
As far as Windows programs are concerned, you are running with administrator privileges. If an application complains about a lack of administrator privileges, file a bug; running Wine as root probably won't help.

-- ... as_root.3F
Posts: 3
Joined: 10 Jan 2016, 18:58

Re: For Linux

Postby pingaan » 18 Feb 2017, 22:55

Any news on this front? I've just signed up for data upload, but I too run Ubuntu. Tried installing via PlayOnLinux, but it instantly fails.
If not, I'll just have to use it on my desktop PC (Windows), once it's set up..

edit: just realized there was a second page to this thread!
It seems you've made a major break through there, Theoden. Did you sort out the supposedly admin issues?
I tried doing what you're doing, only via PlayOnLinux; installing dotnet 2.0, 4.0 and wsh57. The install application won't launch.
[I am not an advanced user of Wine. Please do not hate me for using PlayOnLinux!] :<
Posts: 1
Joined: 16 Feb 2017, 22:07


Return to About/FAQ/Help

Who is online

Users browsing this forum: No registered users and 0 guests